No Output in version 1

TBJLT140

Symptom

After initial power up of console and boot of Vista 1 version 1.13.5295 or earlier the DBO LED remains red and the Grandmaster output does not change in response moving the pot.

Application

All Vista S1 consoles with serial numbers K10321 through K10360 running Jands Vista software versions 1.13.5295 or earlier.

Issue

Manufacturer changes to the LPC chip require specific firmware upgrade.

Parts required

The firmware must be upgraded by applying Jands Vista 1.13.5303 patch release or later. These can be downloaded from http://www.jandsvista.com/download/. This applies to all Jands Vista platforms (Windows, MAC and Console).

Procedure to upgrade firmware

  1. Download Jands Vista Patch release 1.13.5303 from http://www.jandsvista.com/download/
  2. Install according to instructions in release notes.
  3. Restart the computer.
  4. Start the Jands Vista Application.



Change to Video Output Configuration

TBJLT135

Introduction

The Vista I3 video output card has been replaced with an alternative type. The new type results in both physical changes to the console and operational changes to the video outputs. This Tech Note describes the changes.

Application

This change applies to Vista I3 consoles with serial number F09xxx and later.

Change

image004The two graphics card types are shown below.

ZPC9954

Prior to F09xxx

ZPC9960

F09xxx and later





Chassis

Slight physical changes to the chassis to suit the change in DVI connector position require that the correct card be fitted to a particular chassis.

Operation

The change alters how the outputs are allocated at startup.

I3 consoles built prior to the change give the analogue (DB15) connector a higher priority – if an active monitor is found on this port the operating system allocates that monitor as the primary by outputting the Vista main screen to that display.

I3 consoles build after the change however always allocate the digital (DVI) connector as the primary screen – it is not possible to output the Vista main screen to the analogue (DB15) connector. However if it is necessary to run an analogue (DB15) display as the primary display, that display should be connected to the digital (DVI) connector using the DVI to DB15 adaptor supplied with the console.




Vista v2 Crash Dump FIles

Please follow the procedure below to configure a Windows PC controlling the Jands Vista V2 application such that crash dump files may be collected and subsequently analysed in the event of a Vista V2 crash. This procedure is for Microsoft Windows operating systems only.

This procedure must be executed before any crash, as files generated without this application cannot be retrieved or analysed.

Note: Not all crashes will generate a log file. If you experience a crash and no log file is generated, please report all information you can to us.

There are three different procedures – one for XP, another for Microsoft Vista and Windows 7.

Procedure

Setup Procedure for Windows XP:

  1. In the Start menu’s Run box, enter the command “drwtsn32 -i”.
  2. image002

  3. A dialog box will appear informing you that Dr. Watson has been installed as the default debugger. Press OK.
  4. image004


Retrieving Crash Files on Windows XP:

  1. Crash information will be written into the file “C:\Documents and Settings\All Users\Application Data\Microsoft\Dr Watson\user.dmp”. Should a Vista crash occur, navigate to this directory and view the “user.dmp” file.
  2. image006

  3. Check the modification date of the “user.dmp” file to make sure that you are looking at the file that corresponds with when the crash occurred.
  4. Rename the “user.dmp” file to something a more descriptive eg Vista V22-0-6838_20101124_01.dmp”.
  5. Send the crash log file, an exported copy of the show file and a description of what you were doing, to support@jandsvista.com, or use the support contact form at www.jandsvista.com/support

image008Reconfiguring drwtsn32 Settings:

Running drwtsn32 without any options or switches will bring up a window that allows various settings to be changed eg the location of the dump files can be made more easily accessible, or a visual alert letting you know a crash was logged.

If drwtsn32 is reconfigured, please ensure that the checkboxes and radio buttons remain set as per the image to the right.

Additionally the number of crashes to save is limited to 10 by default. Once the limit has been reached, the system will no longer generate new log files. To ensure that data is collected users should periodically remove log files.


Procedure for Windows Vista:

Windows Error Reporting (WER) has been integrated into the Microsoft Vista operating system. By default, Vista uploads the crash logs to Microsoft, but does not save a local copy. To save a local copy of the crash logs, the registry must be reconfigured by following these steps:

  1. Download the file “ActivateCrashDumps.reg” file from the Jands Vista website http://www.jandsvista.com/ActivateCrashDumps.reg. Some browsers helpfully add a “.txt” to the filename (which may not be shown if Windows is hiding file file extensions – see below for details on changing this behavior). The file must have the file extension “.reg”.
  2. Save the file to the PC.
  3. Using Windows Explorer, find the file and double-click on ActivateCrashdumps.reg to run it.
  4. Respond affirmatively to any prompts.
  5. Reboot the PC.

The next time any application crashes, the crash information will be written into a folder located inside “%LOCALAPPDATA%\local\Microsoft\Windows\WER\ReportQueue” (where %LOCALAPPDATA% is usually “c:\Users\user\AppData”). Check the modification date of the directory to make sure that the appropriate directory is being displayed.

image010Windows Vista hides many directories (and files) from the user by default. This can be changed in the Control Panel by selecting Folder Options -> View Tab -> Hidden Files and Folders -> Show Hidden Files).

Each crash will result in a new directory below “ReportQueue”. Package up the entire directory naming each file something more descriptive eg “Vista_1.13.522X_20090720_01.dmp” along with the show file and a brief explanation of what was being done, and email them to support@jandsvista.com.

Procedure for Windows 7:

Log files are automatically generated in Windows 7. These can usually be found at C:\Users\Username\AppData\Local\Microsoft\Windows\WER\ReportArchive however this may vary slightly depending on the configuration of your machine. You may also need to change your settings to view hidden files in order to access these crash logs.




Crash Logs

Retrieving Software Crash Files from a Console

Although unusual software crashes can occur. If they do it is important that as much detail as possible is returned to Jands to enable the cause to be determined and eliminated. In order to simplify this process the console software includes a means to package all of the necessary files for return to Jands support.

To generate a crash report package on a L5, T2, T4 or I3:

  1. Select File -> Quit Application from the main menu, which will open the System Settings dialogue.
  2. If a crash has recently occurred the dialogue will have an additional red button labeled “Export Crash Report”. Click “Export Crash Report”.
  3. Click “Select crash report files”.
  4. There should be at least one file available, but if there’s more select them all using SHIFT + Click or CTRL + Click.
  5. Click “Open”.
  6. If desired you can type some further information into the comment field to describe what was being done when the crash occurred eg “I was in the timeline selection dragging a handle when it crashed”.
  7. Click “Select removable device”.
  8. Select the USB device from the list.
  9. Click “Choose”. The files will be transferred to the USB device.
  10. When it’s finished click “OK”.
  11. Remove the USB memory stick and return the files to Jands via the online support request page http://www.jandsvista.com/support/support-request-form/
  12. Click “Vista 2” to restart the Vista application.

Retrieving Software Crash Files from a Windows PC

Please follow the procedure below to configure a Windows PC controlling the Jands Vista 2 application such that crash dump files may be collected and subsequently analysed in the event of a Vista crash. This procedure is for Microsoft Windows operating systems only.

This procedure must be executed before any crash, as files generated without this application cannot be retrieved or analysed.

Note: Not all crashes will generate a log file. If you experience a crash and no log file is generated, please report all information you can to us.

There are two different procedures – one for XP and another Microsoft Vista.

Setup Procedure for Windows XP:

  1. In the Start menu’s Run box, enter the command “drwtsn32 -i”
  2. AP_drws_1

  3. A dialog box will appear informing you that Dr. Watson has been installed as the default debugger. Press OK.
  4. AP_drws_2

Retrieving Crash Files on Windows XP:

  1. Crash information will be written into the directory “C:\Documents and Settings\All Users\Application Data\Microsoft\Dr Watson. Should a Vista crash occur, navigate to this directory.
  2. AP_drws_3

  3. Check the modification date of the “user.dmp” and “drwtsn32.txt” files to make sure that you are looking at the file that corresponds with when the crash occurred.
  4. Rename the “user.dmp” file to something a more descriptive eg Byron2-0-6838_20101124_01.dmp”.
  5. Send the renamed user.dmp file, an exported copy of the show file, drwtsn32.txt, and a description of what you were doing to support@jandsvista.com, or use the support contact form at www.jandsvista.com/support.

Reconfiguring drwtsn32 Settings:

Running drwtsn32 without any options or switches will bring up a window that allows various settings to be changed eg the location of the dump files can be made more easily accessible, or a visual alert letting you know a crash was logged.

If drwtsn32 is reconfigured, please ensure that the checkboxes and radio buttons remain set as shown in the following image .
AP_drws_4
Additionally the number of crashes to save is limited to 10 by default. Once the limit has been reached, the system will no longer generate new log files. To ensure that data is collected users should periodically remove log files.

Procedure for Windows Vista:

Windows Error Reporting (WER) has been integrated into the Microsoft Vista operating system. By default, Vista uploads the crash logs to Microsoft, but does not save a local copy. To save a local copy of the crash logs, the registry must be reconfigured by following these steps:

  1. Download the file “ActivateCrashDumps.reg” file from the Jands Vista website http://www.jandsvista.com/ActivateCrashDumps.reg . Some browsers helpfully add a “.txt” to the filename (which may not be shown if Windows is hiding file file extensions – see below for details on changing this behavior). The file must have the file extension “.reg”.
  2. Save the file to the PC.
  3. Using Windows Explorer, find the file and double-click on ActivateCrashdumps.reg to run it.
  4. Respond affirmatively to any prompts.
  5. Reboot the PC.

The next time any application crashes, the crash information will be written into a folder located inside “%LOCALAPPDATA%\local\Microsoft\Windows\WER\ReportQueue” (where %LOCALAPPDATA% is usually “c:\Users\user\AppData”). Check the modification date of the directory to make sure that the appropriate directory is being displayed.

Windows Vista hides many directories (and files) from the user by default. This can be changed in the Control Panel by selecting Folder Options -> View Tab -> Hidden Files and Folders -> Show Hidden Files).
AP_drws_5
Each crash will result in a new directory below “ReportQueue”. Package up the entire directory naming each file something more descriptive eg “Vista_1.13.522X_20090720_01.dmp” along with the show file and a brief explanation of what was being done, and email them to support@jandsvista.com.